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PRB: Fingerprint files have disappeared

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This article applies to:

  • MailMarshal (SEG)
  • MailMarshal ECM/MailMarshal Exchange 7.X

Symptoms:

  • Fingerprint files have disappeared.
  • Messages are being stripped of their attachments or are being blocked by a ruleset, although they were previously permitted via the fingerprinting feature.
  • Message contents are not being matched to previously fingerprinted files.
  • Fingerprint files are no longer in the "Valid Fingerprints" folder, causing the messages to be blocked or stripped by a ruleset.

Causes:

  • The fingerprint file may have been deleted manually from the ValidFingerPrints folder
  • MailMarshal will automatically delete your fingerprinting files every six months if the file has not been used by MailMarshal within that time. The default value for this automated deletion is 180 days.

Information:

You can adjust the automatic delete default by adding a value in the MailMarshal registry key or Advanced Settings.

Default locations for this key are:

MailMarshal 10.0 or above:

  • In the Management Console, navigate to Advanced Settings
  • Value name: Engine.FingerprintExpiryDays
  • Type: Integer 
  • Value: Number of days to keep the files

MailMarshal 8.X and below:

  • On the Array Manager, edit the Registry 
  • In version 8.X: HKEY_LOCAL_MACHINE\SOFTWARE\Trustwave\Secure Email Gateway\Default\Engine
  • For full details of the location for each product version, see article Q10832.
  • Value name: FingerprintExpiryDays
  • Type: DWORD
  • Value: Number of days to keep the files (Decimal)

ECM/MailMarshal Exchange 7.X:

  • On the Array Manager, edit the Registry
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Marshal\MMExchange\Default\Engine
  • See also Q14003 for version-specific information
  • Value name: FingerprintExpiryDays
  • Type: DWORD
  • Value: Number of days to keep the files (Decimal)

WARNING:  Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. LevelBlue cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.

This article was previously published as:
NETIQKB29371
Marshal KB256

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