Skip to main content

LevelBlue Named Official Cybersecurity Advisor of the PGA of America. Learn more

LevelBlue Named Official Cybersecurity Advisor of the PGA of America. Learn more

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
PGA of America Partnership
Secure What's Next
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

PRB: MailMarshal Exchange Engine service shows high CPU usage.

Expand / Collapse


This article applies to:

  • MailMarshal Exchange 5.X

Symptoms:

  • MailMarshal for Exchange Engine service shows high CPU usage.

Causes:

Badly formatted email causes the MMEengine to not function porperly when processing the e-mail.

Resolution:

Upgrading to the latest version of MailMarshal Exchange resolves the issue.

Workaround:

Rules can be created to send the badly formatted email via a template and store the original email in a folder for reference. This can be done by following the steps in the order presented:

  1. Create a new Ruleset named Process Badly Formatted Mail.
  2. Enable the When message is incoming Ruleset condition.
  3. In the newly created Ruleset create a new standard rule named Allow valid mail with the rule description the same as the following:

    When a message arrives
    Where message is incoming
    Where message attachment is of type 'EXECUTABLE' or 'IMAGE' or 'VIDEO'' or 'SOUND' or 'DOCUMENT' or 'ARCHIVE' or 'ENCRYPTED' or 'DRAWING' or 'FONTS' or 'OTHER' or 'TNEF' or 'MBODY'
    Pass the message
    on to the next Ruleset.
  4. Under the newly created rule create another standard rule named Block invalid mail with the rule description the same as the following:

    When a message arrives
    Where message is incoming
    Send a 'Bad Mail Template' notification message
    And move the message to 'Badly Formated Mail'

 

The Bad Mail Template can be created within the rule or under the E-mail Template node in the MailMarshal for Exchange Configurator using the following properties:

Template Name: Bad Mail Template
Return Path: {ReturnPath}
From:{Sender}
To:{Recipient}
Subject:{Subject}
Message Body: (Just input a single space from the space bar because this field cannot be null)

The Badly Formatted Mail can be created from within the rule or under the Folders node in the MailMarshal for Exchange Configurator.

Note: The Allow valid mail rule must be at the top of the Process Badly Formatted Mail Ruleset followed by the Block invalid mail rule to function properly.

This article was previously published as:
NETIQKB37988

To contact LevelBlue about this article or to request support:


Rate this Article:
     
Tags:

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.