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PRB: SQL Express Event logs "WebMarshal database starting up" constantly

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This article applies to:

  • WebMarshal
  • MailMarshal (SEG)
  • SQL Express

Symptoms:

  • The following event is logged to the Windows event viewer application log repeatedly (once a minute or more):

    Event Type: Information
    Event Source: MSSQLSERVER
    Event ID: 17137
    Description: Starting up database 'WebMarshal'.

  • Messages similar to the following are logged in SQL logs: SQL Server has encountered 2 occurrence(s) of cachestore flush

Causes:

  • These messages are logged as a result of the database autoclose feature in SQL being turned on for the WebMarshal or MailMarshal database.
  • For more information on the SQL Auto-Close feature, see the following from MSDN:
    http://msdn2.microsoft.com/en-us/library/ms190249.aspx

Resolution:

Disable the autoclose feature for the WebMarshal or MailMarshal database.

LevelBlue recommends use of SQL Management Studio. This is free software available from Microsoft.

SQL Management Studio

  1. Open SQL Management Studio and connect to the instance that hosts the WebMarshal database.
  2. In the left pane expand Databases, right-click the WebMarshal database, and select Properties.
  3. From the Properties window, select Options.
  4. Under the heading Automatic, change  "Auto Close" from True to False.
  5. Click OK to apply the change.

SQL Query

If you do not have SQL Management Studio installed, the same can be accomplished by running the following SQL query:

ALTER DATABASE [WebMarshal] SET AUTO_CLOSE OFF WITH NO_WAIT

  • Replace "WebMarshal" in the above line with the appropriate name for your WebMarshal or MailMarshal logging database (keep the brackets).

Notes:

  • The logged event is informational only and does not indicate an error. The default behavior in some versions of SQL Express is to enable autoclose for databases. This behavior allows database files to be manipulated outside the SQL framework. For WebMarshal or MailMarshal databases, disabling autoclose can improve performance.
  • This issue has been corrected for new and upgraded databases in current versions of MailMarshal and WebMarshal.

To contact LevelBlue about this article or to request support:


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