Skip to main content

LevelBlue Named Official Cybersecurity Advisor of the PGA of America. Learn more

LevelBlue Named Official Cybersecurity Advisor of the PGA of America. Learn more

Services
Cyber Advisory
Managed Cloud Security
Data Security
Managed Detection & Response
Email Security
Managed Network Infrastructure Security
Exposure Management
Security Operations Platforms
Incident Readiness & Response
SpiderLabs Threat Intelligence
Solutions
BY TOPIC
Offensive Security
Solutions to maximize your security ROI
Operational Technology
End-to-end OT security
Microsoft
Unlock the full power of Microsoft Security
Securing the IoT Landscape
Test, monitor and secure network objects
Why LevelBlue
About Us
Awards and Accolades
LevelBlue SpiderLabs
PGA of America Partnership
Secure What's Next
LevelBlue Security Operations Platforms
Security Colony
Partners
Microsoft
Unlock the full power of Microsoft Security
Technology Alliance Partners
Key alliances who align and support our ecosystem of security offerings
Loading...
Loading...

ERRMSG: "pk_mm_users_userid" is not a constraint

Expand / Collapse


This article applies to:

  • MailMarshal SPE
  • Upgrading to 4.0

Symptoms:

  • Database upgrade cannot be completed
  • Error dialog: "pk_mm_users_userid" is not a constraint. Could not drop constraint. See previous errors.

Causes:

  • This issue can be caused if the primary key on the table mm_users is missing or has been renamed.
  • In some cases this key had previously been manually adjusted when resolving issues with very large numbers of users being inserted.

Resolution:

To resolve this issue:

  1. Open the SPE Configuration database using SSMS, and view the properties of the table mm_users (expand tables > mm_users > keys).
  2. Ensure that the primary key pk_mm_users_userid exists (if necessary, rename the primary key for the table).
  3. Re-run the product upgrade. The database upgrade will complete normally.

 


To contact LevelBlue about this article or to request support:


Rate this Article:
     

Add Your Comments


Comment submission is disabled for anonymous users.
Please send feedback to Trustwave Technical Support or the Webmaster
.