This article applies to:
Symptoms:
- Error seen as "toast" pop-up in Console, and in Console log files.
- Failed to fetch server details: The server has not been configured yet - required security data not available
- Some parts of the Console do not load.
- The Controller service log (configuration check) may also indicate that no valid configuration is available.
Causes:
- This error is caused by incomplete loading of configuration in the Array Manager service.
- Because configuration is not fully loaded, the MailMarshal REST API is not available to other components including the Console website.
- The most common reason for this issue is that a Syslog database is configured but not accessible.
Resolution:
For the Syslog related issue:
- Use the MailMarshal Server Tool to verify the configuration and existence of the Syslog database. If necessary update the configuration or create a new database.
Notes:
To check for other possible causes of this error, see the Array Manager text log for a time when the service is restarted.